Usage of old version of Bundle Transformer: LESS with the newest version of Bundle Transformer: Core

Oct 3, 2013 at 6:45 PM
Hi,

First of all I would like to thank you for the great work.
On my current running project I would like to use Bundle Transformer library but I have a specific case. I would like to use old version of Bundle Transformer: LESS extension that has a dependency on dotless library (doesn't use JavaScript engines for transformation). I am aware of the negative aspect of this choice (it doesn't support the latest less version (1.4.1)) but it's ok. The latest Bundle Transformer: LESS version that uses dotless is 1.7.16. According to nuget package specification it requires BundleTransformer.Core (≥ 1.7.16). It seems that it should be ok but to be 100% sure I have the following question:
Is it safe to use the latest BundleTransformer.Core 1.8.2 assembly along with BundleTransformer.Less 1.7.16 assembly?
Coordinator
Oct 4, 2013 at 7:41 AM
Hello, Pavel!

It is not safe. If you are using an older version of BundleTransformer.Less, then use the appropriate version of BundleTransformer.Core.