This project has moved and is read-only. For the latest updates, please go here.

Virtual paths in LESS import directives not resolved anymore?

Apr 16, 2016 at 1:39 AM
Prior to version 1.9, less import paths beginning with a tilde ('~') worked like a charm, meaning I was able to specify application virtual paths like '~/Content/bootstrap/bootstrap.less' and the LESS translator made this path absolute BEFORE actually processing the content.

Beginning with version 1.9 this does not seem to work anymore. Am I right in my assumption, that only relative or absolute paths are allowed, but not virtual ones? Could you please give me a hint about how I could accomplish this again?

It took me hours trying to figuring out by myself, but no luck yet. Thanks in advance.

Apr 16, 2016 at 7:32 PM
Hello, Murat!

In Bundle Transformer 1.9.102 solved this problem.
Apr 18, 2016 at 4:52 PM
Hello Andrey,

thank you, very much appreciated!
Apr 18, 2016 at 5:05 PM
Works like a charm! :-)
Apr 18, 2016 at 5:33 PM
Hello, Murat!

At this point, I recommend upgrading to Bundle Transformer 1.9.103.
Apr 18, 2016 at 5:40 PM
Thanks for the hint, but I saw the second release already on and directly installed the new one, without bothering with 1.9.102.
Apr 19, 2016 at 10:28 PM
Hello Andrey,

unfortunately the same problem also applies to import directives in SASS files. Is there any chance that you fix this in the near future? For a start I can surely live with this limitation though. Background is: we plan to move to Bootstrap 4, hence LESS is not an option anymore (Bootstrap 4 now uses SASS and AutoPrefixer), although we're NOT going to remove LESS support.
Apr 20, 2016 at 9:05 AM
Hello, Murat!

Today I'll start working on this problem.
Apr 20, 2016 at 3:39 PM
Thank you Andrey!
Apr 24, 2016 at 8:05 PM
Hello, Murat!

In Bundle Transformer 1.9.104 solved problem with Sass.
Apr 25, 2016 at 7:10 PM
Hello Andrey,

thank you! again... much appreciated!