This project has moved and is read-only. For the latest updates, please go here.

how do I turn on Less source maps?

Dec 17, 2013 at 11:05 PM
I cant figure out how i would pass the required "–source-map=filename" string to the less compiler. is this possible ?

thanks
Dec 18, 2013 at 7:41 AM
Edited Dec 18, 2013 at 7:42 AM
Hello, Simon!

It is impossible.

In general, none of the Bundle Transformer modules does not support the generation of .map files. The reasons for this are explained in detail in the «MicrosoftAjaxJsMinifier .map file configuration» discussion.

Instead of .map files I recommend to do the following:
  1. Switch a web application to debug mode.
  2. Install the Firefox extension «FireSass for Firebug» and in Web.config file to specify the following settings:
<configuration>
  <bundleTransformer xmlns="http://tempuri.org/BundleTransformer.Configuration.xsd">
    ...
    <less dumpLineNumbers="All">
      ...
    </less>
    ...
  </bundleTransformer>
</configuration>
Dec 18, 2013 at 10:17 PM
Thanks!

I wasnt able to get the plug in to work ( must be our setup ) but showing the line numbers is a great help.
Nov 18, 2014 at 2:01 AM
Hi,

The Firefox extension «FireSass for Firebug» has been removed by its author.

I just used Chrome with the below setting and it worked:
    <less dumpLineNumbers="All">
      ...
    </less>
Tx